Tests being ignored.

Aug 8, 2011 at 3:53 PM

When running my tests, why are they all ignored? This only happens in one of my solutions.

All the required assemblies are referenced.

VS2010, Resharper 6, Agunit 0.4

Coordinator
Aug 8, 2011 at 10:15 PM

This happens when it fails to run the tests.

I suggest you first update to AgUnit 0.4.1, this fixes a nasty bug.

If that doesn't work, you can start visual studio with these command line arguments:
/ReSharper.LogFile "C:\resharper.log" /ReSharper.LogLevel Verbose
This will create a logfile for ReSharper in C:\resharper.log. Please check if there are any exceptions being logged.

Aug 8, 2011 at 11:32 PM

Same issue with 0.4.1 built from source yesterday the Aug. 7. That did fix my issue with no tests being able to run and no test icon next to the test methods.

This solution has Silverlight and Desktop unit test projects. Will this cause an issue? I will attach and see if I hit any exceptions running.

Coordinator
Aug 9, 2011 at 12:14 AM

Running tests for both desktop and Silverlight projects should work.

Try debugging your unit tests, you might see an exception popping up.
You can try turning on "Thrown" exceptions in the Debug > Exceptions dialog. Check the "Thrown" checkbox next to the "Common Language Runtime Exceptions" there. 

Try checking the log file. If there are no exceptions there, and you want to investigate yourself, you can try debugging AgUnit.

Debugging the test run can be hard. ReSharper starts up a separate process to run the tests: JetBrains.ReSharper.TaskRunner.exe, or a variation depending on the platform.
If you want to investigate yourself, you'll have to load up the AgUnit solution, and try debugging the runner.

Use these steps to debug it:

- Remove any AgUnit files you have in your ReSharper plugins folder, the plugin should not be installed/loaded.
- Open the src\AgUnit.sln solution and uncomment "//Debugger.Break();" in AgUnit.Runner.Resharper60.TaskRunner\UnitTestRunner\Silverlight\SilverlightUnitTestTaskRunner.cs
- Now start the AgUnit solution without debugging (ctrl+F5). The DummyTests solution should open in a new Visual Studio instance.
- Open your project's solution in that new Visual Studio instance.
- Run your tests, you should be getting a JIT-debugger dialog.
- Pick the Visual Studio instance with the AgUnit solution to attach. 

 

Nov 9, 2011 at 4:37 PM

Hi.  I'm using 4.2 with resharper 6...same thing.  Tests ignored.  Is everyone using this on resharper 5?  I had high hopes.

Coordinator
Nov 10, 2011 at 11:45 AM

I'm using ReSharper 6 ...

I'm creating a new release for ReSharper 6.1 EAP this weekend. I'll try to include better error handling ...

Nov 10, 2011 at 6:06 PM

Ok. Please post an update.  I'd like to revisit this.