1
Vote

AgUnit 0.9 Resharper 8.2.1 - "No test classes were selected to be in the test run"

description

My Silverlight tests, when run, result it Ignored

I've enabled ReSharper verbose logging and have found the following warning
"WarningMessage=No test classes were selected to be in the test run"

(An aside - to get to this stage I had to copy 32bit versions of ISShims.dll and gpsvc.dll into the AgUnit plugin directory)

My tests, unchanged, were running in Resharper 5.1 with AgUnit 0.3

I'm running VS2010 SP1Rel and using SL5

The only other thing that I can see as slightly awry in the output is
"DiskXapHostFileLoader cannot find file - C:\Program Files (x86)\JetBrains\ReSharper\v8.2\Bin\Plugins\AgUnit\StatLight.Client.For.MSTest2010MayPhone.xap
]]"
which I assume is irrelevant

Why are my tests being ignored? How can I debug this further?

Thanks

comments

SDeKock wrote Sep 18, 2014 at 3:33 PM

MSTest2010MayPhone

Are you using a Windows Phone project?

If not, you may be using the MSTest assemblies from the Windows Phone Toolkit.
Get the correct MSTest assemblies from here: https://silverlight.codeplex.com/

JJ__ wrote Sep 18, 2014 at 4:16 PM

Thanks for the quick reply.

No, not a Windows Phone project (which is why I thought that particular debug message was not relevant).

I've since tried to use StatLight to run the tests and have discovered that it is THAT which is outputting the message "No test classes were selected to be in the test run". There's no other (useful) information from StatLight. Perhaps the additional info that it is StatLights' message may add extra useful info?

I'll post a similar question on the StatLight forum and see if I can get an answer, then I'll post it here.