Error running under Resharper 5.1 EAP

Jun 1, 2010 at 8:20 AM
Edited Jun 1, 2010 at 8:21 AM

I get the following error running under Resharper 5.1 EAP:

The plugin AgUnit.Runner.Common could not be loaded from "...(omitted for brevity)...\AgUnit.Runner.Common.dll".

Could not load file or assembly '...(omitted for brevity)...\AgUnit.Runner.Common.dll' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

What would I need to do to load/build this? any ideas?

Jun 1, 2010 at 12:11 PM
Edited Jun 6, 2010 at 12:58 PM

It currently only works with Visual Studio 2010, support for 2008 is planned for next release.

I tried it already to just change the target framework version, but you will just get another error when loading the plugin.

Jun 1, 2010 at 1:05 PM

I'm getting the same error using VS2010 + R# 5.1 (EAP Build 5.1.1700.249)

I didn't see any install instructions, so I just unzipped the download to C:\Program Files (x86)\JetBrains\ReSharper\v5.1\Bin\Plugins\AgUnit-0.1-ReSharper5.0.  Any thing else required?

I'm wondering if 5.1 is the issue?

I'd be happy to help test if you need a hand

Jun 1, 2010 at 1:08 PM
Edited Jun 1, 2010 at 1:13 PM

I'm using the same build of R# as you and it works here, so that's not the problem.

Are you using a beta / RC version of Visual Studio or .NET ?

Jun 1, 2010 at 1:12 PM

Nope - Just double checked my about window:

Microsoft Visual Studio 2010 Ultimate
Version 10.0.30319.1 RTMRel

I'm rolling back to R# 5 right now (5.1 didn't fix my performance issues).  I'll try installing again with 5.0 and report back

Jun 1, 2010 at 1:16 PM

Thanks. I look forward to the 2008 version.

I find it amazing how often it so happens that as I need something, someone has just blogged about it or created an open source project for it. I love the open source community!!! Well done for putting this out. I can't wait to use it!

-Mark

Jun 1, 2010 at 1:49 PM

I'm seeing the same problem on 5.0

Plugin Load Failure:  http://s716.photobucket.com/albums/ww166/kbrownsberger/AgUnitErrors/?action=view&current=loadfailure.png

VS About:  http://s716.photobucket.com/albums/ww166/kbrownsberger/AgUnitErrors/?action=view&current=vsabout.png

R# About: http://s716.photobucket.com/albums/ww166/kbrownsberger/AgUnitErrors/?action=view&current=resharperabout.png

Here's my install directory:

 Volume in drive C is OSDisk
 Volume Serial Number is 581C-A250

 Directory of C:\Program Files (x86)\JetBrains\ReSharper\v5.0\Bin\Plugins

06/01/2010  07:44 AM    <DIR>          .
06/01/2010  07:44 AM    <DIR>          ..
06/01/2010  07:32 AM    <DIR>          AgUnit-0.1-ReSharper5.0
06/01/2010  07:46 AM                 0 out.out
               1 File(s)              0 bytes

 Directory of C:\Program Files (x86)\JetBrains\ReSharper\v5.0\Bin\Plugins\AgUnit-0.1-ReSharper5.0

06/01/2010  07:32 AM    <DIR>          .
06/01/2010  07:32 AM    <DIR>          ..
06/01/2010  07:32 AM           958,976 AgUnit.Runner.Common.dll
06/01/2010  07:32 AM            44,544 AgUnit.Runner.Common.pdb
06/01/2010  07:32 AM            72,192 AgUnit.Runner.Resharper50.dll
06/01/2010  07:32 AM            58,880 AgUnit.Runner.Resharper50.pdb
06/01/2010  07:32 AM           517,632 Ionic.Zip.dll
06/01/2010  07:32 AM           433,664 Ionic.Zip.pdb
06/01/2010  07:32 AM           631,222 Ionic.Zip.xml
06/01/2010  07:32 AM               612 LICENSE.txt
               8 File(s)      2,717,722 bytes

     Total Files Listed:
               9 File(s)      2,717,722 bytes
               5 Dir(s)  48,115,073,024 bytes free

Jun 1, 2010 at 1:52 PM
Edited Jun 1, 2010 at 1:53 PM

Can you check if the assembly is not blocked by windows.

Right click > Properties > "Unblock" button. 

Do the same for the Ionic.Zip assembly.

Jun 1, 2010 at 3:17 PM

That did the trick - I'm running now.  Thanks!

Jun 1, 2010 at 3:27 PM

Hmmm... I don't have the unlock button.

I am running Windows 7.

Oh well. I wait in anticipation for the VS2008 version :)

Jun 1, 2010 at 3:34 PM

If you don't have the Unblock button, it's not blocked ... :)

Jun 14, 2010 at 3:59 PM
Hi There. Any idea when the VS2008 version will be released? Unfortunately I haven't been able to use this plugin yet because of this issue... Thanks again.
Jun 14, 2010 at 4:16 PM
Edited Jul 20, 2010 at 9:06 AM

I'm working on the Silverlight version multi-targeting in my local repository.
You can try building the current source code, it will work with vs2008 but your tests will still run in Silverlight 4.