Non-Ag Unit Tests no longer run?

Mar 23, 2011 at 8:15 PM

After installing AgUnit (a custom build against 5.1.3), the Ag unit tests run great.  But now when I try to run non-Ag unit tests, I get an error dialog:

"Unhandled Error in Silverlight Application", "Code: 2105", "Category: Initialize Error", "Message: Failed to load pre-requisites for the application"

I also get a AgUnit window (I can find it in my Alt-Tab window list).  My test runner in VS is hung until I close that window.  Then the test runner ends, but my test is un-executed.

Did I configure something wrong?

Mar 23, 2011 at 8:34 PM

Hi Trinition,

It looks like AgUnit is trying to run the MSTest tests.

I've never used MSTest myself, I've always tried to avoid it and use NUnit or xUnit. But in the simple test cases I've tried, it works.
Could you create a simple solution for me where you can reproduce this in ? I'll try to resolve your problem as soon as I can.

The window you are seeing is the WinForm with the WebBrowser control AgUnit uses in the background.
Another way to kill it when it hangs like this, is to kill the JetBrains.TaskRunner.exe process with task manager.

Greetings,

Steven