Not able to run tests at all

May 6, 2011 at 8:41 PM

And so i tried everything mentioned in the previous discussions and on the agunit web site but i just cant get the tests to run at all. When i try to run/debug tests, i see a green line with small rectangles against the screen but there is no run, no error mesage, nothing and it just simply does not do anything.

i checked task manager and could not see any "Jetbrains.Resharper.TaskRunner.exe" executable too.

Help! And this is first time i have downloaded and installed this plugin with Resharper 5.1

May 6, 2011 at 8:47 PM


This usually happens when you have a build of AgUnit that is for a different version of Resharper.
Make sure you have the correct version of AgUnit.

I don't have a build for version 5.1.3 of Resharper yet, but I'm planning to create one before monday.

If this doesn't solve your problem, feel free to contact me.



May 6, 2011 at 8:58 PM

thanks for the reply. thsi is what i have. and you are right i do have 5.1.3. i will try this out on monday


JetBrains ReSharper 5.1 C# Edition

Build 5.1.3000.12 on 2011-01-28T05:05:56 

Plugins: 1

#1. “AgUnit for R# 5.1” v0.2.0.0 by “”

Visual Studio 10.0.30319.1.


Copyright © 2003–2011 JetBrains s.r.o.. All rights reserved.

May 9, 2011 at 11:12 PM


The 0.3 release of AgUnit is online, you can now use it with ReSharper 5.1.3.

Let me know how it turns out.



May 9, 2011 at 11:51 PM

Thanks for the update. I did install version 0.3 but same result as before

This is what I see under Resharper->Help->About Jetbrains Resharper

JetBrains ReSharper 5.1 C# Edition
Build 5.1.3000.12 on 2011-01-28T05:05:56

Plugins: 1
#1. “AgUnit 0.3 for R# 5.1.3” v0.3.0.0 by “”
Visual Studio 10.0.30319.1.

Copyright © 2003–2011 JetBrains s.r.o.. All rights reserved.

May 10, 2011 at 9:21 AM
Edited May 10, 2011 at 9:22 AM

Can you make sure that your test project has all of these references:

System.Xml.Linq <= This one isn't added by default

Missing any of these fails to run the tests, without any error message.

I hope that helps. If it doesn't, let me know!


May 10, 2011 at 8:06 PM

Yes, i did verify that i have all the above, And i did add the Linq one as well. But no luck

May 11, 2011 at 9:11 AM

I found an issue in AgUnit 0.3 that when using "Run unit tests" in the Solution explorer doesn't work all the time.
The fix for this issue will be available in one of the upcoming days. 

Can you try running one test individually, using the unit test "bullets" in the code window and see if that works ?

May 11, 2011 at 8:49 PM

Neither  the 'Run Unit Tests' nor the bullet way from the test method in code works. Sorry, I seem to be the bearer of bad news each time.

May 11, 2011 at 8:58 PM

Just exploring all possible options :)

Can you try using both "Debug" and "Silverlight debug" when having "Thrown" CLR Exceptions enabled (in the Debug > Exceptions menu)
and see if that shows you any error message.

Can you debug normal Silverlight applications from within visual studio ?

May 11, 2011 at 9:08 PM

i did enable 'Thrown' exceptions for the entire CLR Exceptions category and yet did not see any error messages for both debug and SL debug


Also, yes, i can very well debug SL apps in VS. Just that I am unable to run unit tests for the same app using Resharper with AgUnit. I can run tests using Silverlight Unit Test Framework

May 11, 2011 at 10:10 PM
Edited May 11, 2011 at 10:12 PM


Can you start visual studio with these command line parameters (create a shortcut to visual studio and add them to the target):

/ReSharper.LogFile "C:\log.txt" /ReSharper.LogLevel Verbose

This should create a log file for ReSharper at C:\log.txt.

Try running a test and see if any exception shows up in the log.


If this doesn't work, I'll send you a custom build of AgUnit that has the browser window visible.