AgUnit not working with nunit-Silverlight

Sep 16, 2011 at 8:36 AM

I tried AgUnit 0.4.2 using Visual Studio 2010 Professional, ReSharper 6 in a Silverlight Test project, using the MSTest the Unit Tests working fine. But when I tried nunit-Silverlight instead of MSTest I don't get the ReSharper Icons on the left, and a right click -> run tests doesn't work either. Running the tests using statLight works just fine though.

Any ideas what to do?

Sep 21, 2011 at 10:23 AM

Which nunit-Silverlight are you using? Because there are a lot of different Silverlight ports. And most of them don't work properly.
I've had success using this one:

Also make sure you have enabled the NUnit test provider in the ReSharper options.

Sep 21, 2011 at 12:54 PM

That's the one I was using.

Today I found that deleting that project from my solution and add it again enabled the unit tests. Then I created a new project using nunit-silverlight for testing, the ReSharper symbols didn't appear, but a restart of Visual Studio helped this time. So it works now, but it isn't that reliable for some reasons.