Failed to loast test assembly

Apr 24, 2012 at 9:45 AM



I'm using Visual Studio 2010 Professional, ReSharper 6.1, AgUnit 0.5 preRelease (also tried the latest official release before) and the latest nunit Silverlight from here (2010 seems to be quite old though...)

When I try to run a Test via ReSharper I get an error message saying

"Unit Test Runner filaed to load test assembly

System.IO.FileNotFoundException: The file or assembly 'System.Windows, Version=, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' or a dependency of it was not found. The system can't find the specified file."


Message is in german here, I translated it myself.

When I use statlight to run the tests they work just fine.

I'm not sure if AgUnit is the problem or not, but I hope you can help me.


May 28, 2012 at 9:37 PM

Hi, can you check that the AgUnit plugin was loaded ?
You can check this in the ReSharper options under the Plugins section.

A common problem is the AgUnit .dll's and related files being blocked by Windows.
You can check this by rightclicking AgUnit.Runner.Resharper61.dll and clicking properties.
If you see an "Unblock" button, the file is blocked.
You can then either unblock each file individually this way, but I advise you to download AgUnit again and Unblock the whole .zip file before extracting.

If this doesn't solve your problem, let us know and we'll investigate further !

May 30, 2012 at 7:10 AM



I found this version to be working just fine

When I downgraded Rhesharper to 6.0 the official AgUnit version worked again. So it was a compability problem.

Now I see that there was a new release in the mean time, I will try that later.

Thanks guys!