AgUnit 0.7 with ReSharper 7.1 doesn't seem to work

Nov 15, 2012 at 1:01 AM

Hi, I'm just trying out AgUnit 0.7 with R# 7.1 / VS 2012 at the moment.

The plugin appears to load fine, but when I run my Silverlight tests now it's clearly not using the Silverlight runtime as I get all the same errors as I do when I disable the plugin and run the tests.

Can you investigate please?



Nov 15, 2012 at 8:09 PM


Can you make sure non of the .dll's are blocked in Windows ?

You can unblock the .zip file as a whole before extracting it if that is the case.

If it's not the case, we'll have to do some debugging ...

Nov 15, 2012 at 11:22 PM

I redownloaded the AgUnit zip, unblocked it, extracted and updated my plugins directory, but still the same problems - I've verified that none of the files are blocked.

What can I try next?

Nov 16, 2012 at 7:48 AM

Can you send me a screenshot of:

- R# Options > Plugins screen with "Show details"
- R# Options > Unit Testing
- R# Options > Unit Testing > MSTest (or NUnit if you're using that in your Silverlight tests)

Attach a ReSharper log:

Start visual studio like this:

devenv /ReSharper.LogFile "C:\resharper.log" /ReSharper.LogLevel Verbose

Do a test run.

You'll find the logfile in C:\resharper.log.

Nov 18, 2012 at 10:35 PM
Edited Nov 19, 2012 at 9:53 PM

OK done.

Can you send me your contact email address so I can mail you the attachments?



Nov 19, 2012 at 11:13 AM

I got a "recipient not found" bounce email on that address.
You might want to edit your post and remove it ... it shouldn't be displayed publicly I guess :) 

You can use the contact form to contact me in private:

Or you can create an issue and attach the files to it.

Nov 19, 2012 at 9:54 PM

That was the wrong email, d'oh. I'll create an issue.

Nov 19, 2012 at 10:00 PM

Issue 6454 created with attachments.